Imagine Math Incident
Incident Report for Imagine Learning
Resolved
We are pleased to announce that the Imagine Math platform is now functioning normally. We apologize for the problems reported earlier, and are confident that the underlying issue has been fixed.

If you are still experiencing issues, please reach out to Customer Support.
Posted Apr 07, 2021 - 12:57 MDT
Monitoring
We are pleased to announce that the Imagine Math platform is currently functioning normally. As previously reported, students were having difficulty logging in and using the platform and educators were having difficulty ogging in and using the platform.

--

Our Operations team has implemented a solution and it appears to have resolved this issue. We will actively monitor the service to ensure the issues do not recur. Thank you for your patience.
Posted Apr 07, 2021 - 07:22 MDT
Investigating
The Imagine Math platform is currently in a degraded state.

Students may have difficulty logging in to the platform or using the platform.

Educators may also have difficulty logging in to the platform or using the platform.

Our Operations team is currently engaged and investigating the issue. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Apr 07, 2021 - 07:00 MDT
This incident affected: Imagine Math Student Access (Math PreK-2, Math 3+, Math Facts).