Imagine Edgenuity Unavailable
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Dec 07, 2022 - 12:33 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Dec 07, 2022 - 12:04 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy and Imagine Purpose Prep 6-12.

Students and Educators may be unable to access the impacted products.

We apologize for the inconvenience and will provide an update soon.
Posted Dec 07, 2022 - 11:49 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).