Imagine EdgeEX - Slow Page Loading

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 14, 2025 - 11:38 MST

Investigating

Our team is actively investigating an issue impacting users of Imagine EdgeEX.

Students and educators may encounter intermittent issues with pages loading.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 14, 2025 - 11:15 MST
This incident affected: Courseware (Imagine EdgeEX).