Instructional Services and Academies - Some Students Cannot Open Imagine Edgenuity

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 21, 2026 - 12:29 MST

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted May 21, 2026 - 11:19 MST

Investigating

Our team is actively investigating an issue impacting Instructional Services and Academies. Some students receive an error message when they attempt to open Imagine Edgenuity courses. Users can clear their browser cookies to resolve this situation temporarily. The team is preparing a more permanent solution as well.

We apologize for the inconvenience and will provide an update soon.
Posted May 20, 2026 - 09:55 MST
This incident affected: Virtual School Services (Imagine Instructional Services) and Academies (Brightspire Virtual Schools, Giant Campus, Ignitia Virtual Academy, Imagine Learning Excellence Academy, Park City Independent).