Instructional Services and Academies - Cannot Log In

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Mar 19, 2026 - 15:05 MST

Investigating

Our team is actively investigating an issue impacting users of Instructional Services and Academies.

Users are not able to log in from the Imagine Learning Virtual Portal.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 19, 2026 - 14:51 MST
This incident affected: Virtual School Services (Imagine Instructional Services) and Academies (Brightspire Virtual Schools, Giant Campus, Ignitia Virtual Academy, Imagine Learning Excellence Academy, Park City Independent).