We are happy to report that users should now be able to resume activities without difficulty.
We apologize for the prior inconvenience.
Posted Apr 14, 2025 - 10:52 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted Apr 13, 2025 - 19:34 MST
Identified
We are continuing to work on a fix for this issue.
Posted Apr 13, 2025 - 19:33 MST
Investigating
We are continuing to investigate this issue.
Posted Apr 13, 2025 - 19:04 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.
We will continue to update progress.
Posted Apr 13, 2025 - 18:57 MST
Update
We are continuing to investigate this issue.
Posted Apr 13, 2025 - 18:56 MST
Update
We are continuing to investigate this issue.
Posted Apr 13, 2025 - 18:47 MST
Investigating
Our team is actively investigating an issue impacting District Administrators.
The set of Administrator reports for Imagine Edgenuity and Imagine EdgeEx and Cumulative Progress Reports for Imagine MyPath, Imagine Language & Literacy, and Imagine Español do not load. The users see either an error or blank page.
We apologize for the inconvenience and will provide an update soon.
Posted Apr 13, 2025 - 18:15 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX) and Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español).