Clever via SAML SSO Experiencing Issues

Incident Report for Imagine Learning

Resolved

Clever has reported that they are now operational.
Posted Feb 10, 2026 - 16:00 MST

Update

We are continuing to investigate this issue.
Posted Feb 10, 2026 - 14:24 MST

Investigating

We have been notified by Clever that their service is degraded. For more information, please visit their status page status.Clever.com
Posted Feb 10, 2026 - 14:23 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX, Imagine Odysseyware), Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine Math, Imagine Math Facts, Imagine Purpose 6-12, Imagine+ Assessment), and Core Curriculum (Imagine Learning Illustrative Mathematics).