Incident with Multiple Imagine Learning Products

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jun 12, 2025 - 13:40 MST

Monitoring

Our products have recovered at this point, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Jun 12, 2025 - 13:24 MST

Investigating

Our team is actively investigating an issue impacting users of multiple Imagine Learning Products. It appears that this issue is related to stability with our underlying cloud provider.

Students and Educators may have issues connecting to the impacted products.

We apologize for the inconvenience and will provide an update soon.
Posted Jun 12, 2025 - 13:11 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX, Imagine Odysseyware), Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Lectura, Imagine Reading, Imagine Galileo, Imagine Purpose K-5, Imagine Math, Imagine Math Facts, Imagine Robotify, Imagine MyPath Legacy, Imagine Purpose 6-12, Imagine Science Corner), and Core Curriculum (Twig Science).