ClassLink SSO experiencing issues

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 15:45 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 15:36 MST

Update

We are continuing to investigate this issue.
Posted Oct 27, 2025 - 15:34 MST

Investigating

We have been notified by ClassLink that they are seeing issues surrounding logging in to My Apps. For more information, please visit their status page https://status.classlink.com/incidents/jtg7jtff3rnp
Posted Oct 27, 2025 - 15:24 MST
This incident affected: Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education, Twig Science, Traverse), Courseware (Imagine Edgenuity, Imagine EdgeEX, Imagine Odysseyware), and Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine Math Facts, Imagine Purpose 6-12).