Twig Science Elementary – Students unable to log in

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 06:25 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 06:23 MST

Update

We are continuing to work on a fix for this issue. The Twig Science Elementary issues have been resolved but Twig Science Tools is still having issues that we are working through.
Posted Sep 05, 2025 - 06:04 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 05, 2025 - 05:35 MST

Investigating

Our team is actively investigating an issue impacting users of Twig Science Elementary.

Students are unable to login.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 05, 2025 - 05:22 MST
This incident affected: Core Curriculum (Twig Science).